THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Fathom (Privacy friendly web analytics)
Zendesk (Helpdesk and Chat)

Ok

Home | EN
Support
CVE
PUBLISHED

CVE-2024-6624

JSON API User <= 3.9.3 - Unauthenticated Privilege Escalation

AssignerWordfence
Reserved2024-07-09
Published2024-07-11
Updated2024-07-24

Description

The JSON API User plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 3.9.3. This is due to improper controls on custom user meta fields. This makes it possible for unauthenticated attackers to register as administrators on the site. The plugin requires the JSON API plugin to also be installed.



CRITICAL: 9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Problem types

CWE-269 Improper Privilege Management

Product status

Default status
unaffected

*
affected

Timeline

2024-07-10:Disclosed

Credits

Thanh Nam Tran finder

References

https://www.wordfence.com/threat-intel/vulnerabilities/id/a4a26f60-5912-4d4a-8ef8-e4357c1fb1ff?source=cve

https://plugins.trac.wordpress.org/browser/json-api-user/trunk/controllers/User.php#L51

https://plugins.trac.wordpress.org/browser/json-api-user/trunk/controllers/User.php#L187

https://plugins.trac.wordpress.org/changeset/3115185/

cve.org CVE-2024-6624

nvd.nist.gov CVE-2024-6624

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-6624
© Copyright 2024 THREATINT. Made in Cyprus with +