THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Fathom (Privacy friendly web analytics)
Zendesk (Helpdesk and Chat)

Ok

Home | EN
Support
CVE
PUBLISHED

CVE-2024-6391

oik <= 4.10.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via bw_button Shortcode

AssignerWordfence
Reserved2024-06-27
Published2024-07-09
Updated2024-07-09

Description

The oik plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's bw_button shortcode in all versions up to, and including, 4.10.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



MEDIUM: 6.4CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Problem types

CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Product status

Default status
unaffected

*
affected

Timeline

2024-07-08:Disclosed

Credits

Rafshanzani Suhada finder

References

https://www.wordfence.com/threat-intel/vulnerabilities/id/d3dfa92a-57da-49ab-95f7-504fa99ed47f?source=cve

https://wordpress.org/plugins/oik/#developers

https://plugins.trac.wordpress.org/browser/oik/trunk/shortcodes/oik-button.php#L34

https://plugins.trac.wordpress.org/changeset/3112763/

cve.org CVE-2024-6391

nvd.nist.gov CVE-2024-6391

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-6391
© Copyright 2024 THREATINT. Made in Cyprus with +