THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Fathom (Privacy friendly web analytics)
Zendesk (Helpdesk and Chat)

Ok

Home | EN
Support
CVE
PUBLISHED

CVE-2024-6365

Product Table by WBW <= 2.0.1 - Unauthenticated Remote Code Execution

AssignerWordfence
Reserved2024-06-27
Published2024-07-09
Updated2024-07-09

Description

The Product Table by WBW plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 2.0.1 via the 'saveCustomTitle' function. This is due to missing authorization and lack of sanitization of appended data in the languages/customTitle.php file. This makes it possible for unauthenticated attackers to execute code on the server.



CRITICAL: 9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Problem types

CWE-94 Improper Control of Generation of Code ('Code Injection')

Product status

Default status
unaffected

*
affected

Timeline

2024-07-08:Disclosed

Credits

Friderika Baranyai finder

References

https://www.wordfence.com/threat-intel/vulnerabilities/id/ba84711f-bdbe-46d3-a9a3-cc2b1dcefd1a?source=cve

https://plugins.trac.wordpress.org/browser/woo-product-tables/trunk/modules/wootablepress/models/wootablepress.php#L7

https://plugins.trac.wordpress.org/browser/woo-product-tables/trunk/languages/customTitle.php

https://plugins.trac.wordpress.org/changeset/3113335/

cve.org CVE-2024-6365

nvd.nist.gov CVE-2024-6365

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-6365
© Copyright 2024 THREATINT. Made in Cyprus with +