THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Fathom (Privacy friendly web analytics)
Zendesk (Helpdesk and Chat)

Ok

Home | EN
Support
CVE
PUBLISHED

CVE-2024-6319

IMGspider <= 2.3.10 - Authenticated (Contributor+) Arbitrary File Upload via 'upload'

AssignerWordfence
Reserved2024-06-25
Published2024-07-04
Updated2024-07-08

Description

The IMGspider plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'upload' function in all versions up to, and including, 2.3.10. This makes it possible for authenticated attackers, with contributor-level and above permissions, to upload arbitrary files on the affected site's server which may make remote code execution possible.



HIGH: 8.8CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Problem types

CWE-434 Unrestricted Upload of File with Dangerous Type

Product status

Default status
unaffected

*
affected

Timeline

2024-06-25:Discovered
2024-06-25:Vendor Notified
2024-07-03:Disclosed

Credits

István Márton finder

References

https://www.wordfence.com/threat-intel/vulnerabilities/id/63a4a077-c99e-4742-9fa1-f323fd24b950?source=cve

https://plugins.trac.wordpress.org/browser/imgspider/tags/2.3.10/classes/post.class.php#L189

https://plugins.trac.wordpress.org/changeset/3107741/imgspider

cve.org CVE-2024-6319

nvd.nist.gov CVE-2024-6319

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-6319
© Copyright 2024 THREATINT. Made in Cyprus with +