THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Fathom (Privacy friendly web analytics)
Zendesk (Helpdesk and Chat)

Ok

Home | EN
Support
CVE
PUBLISHED

CVE-2024-6314

IQ Testimonials <= 2.2.7 - Unauthenticated Arbitrary File Upload

AssignerWordfence
Reserved2024-06-25
Published2024-07-09
Updated2024-07-09

Description

The IQ Testimonials plugin for WordPress is vulnerable to arbitrary file uploads due to insufficient file type validation in the 'process_image_upload' function in versions up to, and including, 2.2.7. This makes it possible for unauthenticated attackers to upload arbitrary files on the affected site's server which may make remote code execution possible. This can only be exploited if the 'gd' php extension is not loaded on the server.



CRITICAL: 9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Problem types

CWE-434 Unrestricted Upload of File with Dangerous Type

Product status

Default status
unaffected

*
affected

Timeline

2024-06-24:Discovered
2024-06-24:Vendor Notified
2024-07-08:Disclosed

Credits

István Márton finder

References

https://www.wordfence.com/threat-intel/vulnerabilities/id/bec50640-a550-49a8-baf6-2dd53995f90b?source=cve

https://plugins.trac.wordpress.org/browser/iq-testimonials/tags/2.2.7/lib/iq-testimonials-form.php#L296

cve.org CVE-2024-6314

nvd.nist.gov CVE-2024-6314

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-6314
© Copyright 2024 THREATINT. Made in Cyprus with +