THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Fathom (Privacy friendly web analytics)
Zendesk (Helpdesk and Chat)

Ok

Home | EN
Support
CVE
PUBLISHED

CVE-2024-6307

WordPress Core < 6.5.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via HTML API

AssignerWordfence
Reserved2024-06-25
Published2024-06-25
Updated2024-07-06

Description

WordPress Core is vulnerable to Stored Cross-Site Scripting via the HTML API in various versions prior to 6.5.5 due to insufficient input sanitization and output escaping on URLs. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



MEDIUM: 6.4CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Problem types

CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Product status

Default status
unaffected

5.9
affected

6.0
affected

6.1
affected

6.2
affected

6.3
affected

6.4
affected

6.5
affected

Timeline

2024-06-24:Disclosed

Credits

Alex Concha finder

Dennis Snell finder

Grzegorz Ziółkowski finder

Aaron Jorbin finder

References

https://www.wordfence.com/threat-intel/vulnerabilities/id/bc0d36f8-6569-49a1-b722-5cf57c4bb32a?source=cve

https://wordpress.org/news/2024/06/wordpress-6-5-5/

https://core.trac.wordpress.org/changeset/58473

https://core.trac.wordpress.org/changeset/58472

cve.org CVE-2024-6307

nvd.nist.gov CVE-2024-6307

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-6307
© Copyright 2024 THREATINT. Made in Cyprus with +