THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-5758

Post Grid Gutenberg Blocks and WordPress Blog Plugin – PostX <= 4.0.4 - Authenticated (Contributor+) Stored Cross=Site Scripting

Reserved:2024-06-07
Published:2024-06-08
Updated:2024-06-10

Description

The Post Grid Gutenberg Blocks and WordPress Blog Plugin – PostX plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the filterMobileText parameter in all versions up to, and including, 4.0.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



MEDIUM: 6.4CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Problem types

CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Product status

Default status
unaffected

*
affected

Timeline

2024-05-27:Disclosed

Credits

Dmitrii Ignatyev finder

References

https://www.wordfence.com/threat-intel/vulnerabilities/id/4dcc3f47-8504-4aa6-af60-03edeaa39fd7?source=cve

https://research.cleantalk.org/cve-2024-4305/

https://wpscan.com/vulnerability/635be98d-4c17-4e75-871f-9794d85a2eb1/

https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3088956%40ultimate-post%2Ftrunk&old=3076390%40ultimate-post%2Ftrunk&sfp_email=&sfph_mail=

cve.org CVE-2024-5758

nvd.nist.gov CVE-2024-5758

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-5758