THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Fathom (Privacy friendly web analytics)
Zendesk (Helpdesk and Chat)

Ok

Home | EN
Support
CVE
PUBLISHED

CVE-2024-5753

Local File Read (LFI) by Prompt Injection via Postgres SQL in vanna-ai/vanna

Assigner@huntr_ai
Reserved2024-06-07
Published2024-07-05
Updated2024-07-08

Description

vanna-ai/vanna version v0.3.4 is vulnerable to SQL injection in some file-critical functions such as `pg_read_file()`. This vulnerability allows unauthenticated remote users to read arbitrary local files on the victim server, including sensitive files like `/etc/passwd`, by exploiting the exposed SQL queries via a Python Flask API.



HIGH: 7.5CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Problem types

CWE-200 Exposure of Sensitive Information to an Unauthorized Actor

Product status

Any version
affected

References

https://huntr.com/bounties/a3f913d6-c717-4528-b974-26d8d9e839ca

cve.org CVE-2024-5753

nvd.nist.gov CVE-2024-5753

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-5753
© Copyright 2024 THREATINT. Made in Cyprus with +