THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-5654

CF7 Google Sheets Connector <= 5.0.9 - Missing Authorization to Limited Site Configuration Update

Reserved:2024-06-05
Published:2024-06-08
Updated:2024-06-10

Description

The CF7 Google Sheets Connector plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'execute_post_data_cg7_free' function in all versions up to, and including, 5.0.9. This makes it possible for unauthenticated attackers to toggle site configuration settings, including WP_DEBUG, WP_DEBUG_LOG, SCRIPT_DEBUG, and SAVEQUERIES.



MEDIUM: 6.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Problem types

CWE-862 Missing Authorization

Product status

Default status
unaffected

*
affected

Timeline

2024-06-07:Disclosed

Credits

1337_Wannabe finder

References

https://www.wordfence.com/threat-intel/vulnerabilities/id/c0da4d55-5025-47cf-9f45-377d8943fc94?source=cve

https://plugins.trac.wordpress.org/browser/cf7-google-sheets-connector/trunk/includes/class-gs-service.php#L52

https://plugins.trac.wordpress.org/changeset/3099184/

cve.org CVE-2024-5654

nvd.nist.gov CVE-2024-5654

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-5654