THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-5530

ShopLentor – WooCommerce Builder for Elementor & Gutenberg +12 Modules – All in One Solution (formerly WooLentor) <= 2.9.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via WL Product Horizontal Filter Widget

Reserved:2024-05-30
Published:2024-06-11
Updated:2024-06-11

Description

The ShopLentor – WooCommerce Builder for Elementor & Gutenberg +12 Modules – All in One Solution (formerly WooLentor) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's WL: Product Horizontal Filter widget in all versions up to, and including, 2.9.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



MEDIUM: 6.4CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Problem types

CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Product status

Default status
unaffected

*
affected

Timeline

2024-06-10:Disclosed

Credits

wesley finder

References

https://www.wordfence.com/threat-intel/vulnerabilities/id/3fc2c2df-b590-413f-ba07-5aa645d069b8?source=cve

https://plugins.trac.wordpress.org/browser/woolentor-addons/tags/2.8.9/includes/addons/wl_product_horizontal_filter.php#L1091

https://plugins.trac.wordpress.org/changeset/3100260/woolentor-addons/trunk/includes/addons/wl_product_horizontal_filter.php

cve.org CVE-2024-5530

nvd.nist.gov CVE-2024-5530

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-5530