THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-5126

Improper Access Control in lunary-ai/lunary

Reserved:2024-05-19
Published:2024-06-06
Updated:2024-06-07

Description

An improper access control vulnerability exists in the lunary-ai/lunary repository, specifically within the versions.patch functionality for updating prompts. Affected versions include 1.2.2 up to but not including 1.2.25. The vulnerability allows unauthorized users to update prompt details due to insufficient access control checks. This issue was addressed and fixed in version 1.2.25.



HIGH: 7.6CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L

Problem types

CWE-284 Improper Access Control

Product status

Any version before 1.2.25
affected

References

https://huntr.com/bounties/8e7e1267-ea6c-4789-b9dc-3410dfac6ec6

https://github.com/lunary-ai/lunary/commit/b7bd3a830a0f47ba07d0fd57bf78c4dd8a216297

cve.org CVE-2024-5126

nvd.nist.gov CVE-2024-5126

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-5126