THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-4422

Comparison Slider <= 1.0.5 - Authenticated (Subscriber+) Stored Cross-Site Scripting

Reserved:2024-05-02
Published:2024-05-30
Updated:2024-06-06

Description

The Comparison Slider plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the slider title parameter in all versions up to, and including, 1.0.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



MEDIUM: 6.4CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Problem types

CWE-862 Missing Authorization

Product status

Default status
unaffected

*
affected

Timeline

2024-05-29:Disclosed

Credits

Benedictus Jovan finder

References

https://www.wordfence.com/threat-intel/vulnerabilities/id/0907c74e-0bb8-4761-aabf-79d880c78415?source=cve

https://wordpress.org/plugins/comparison-slider/

cve.org CVE-2024-4422

nvd.nist.gov CVE-2024-4422

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-4422