THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-4364

Qi Addons For Elementor <= 1.7.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via Button Widget

Reserved:2024-04-30
Published:2024-06-06
Updated:2024-06-06

Description

The Qi Addons For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's button widgets in all versions up to, and including, 1.7.2 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



MEDIUM: 6.4CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Problem types

CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Product status

Default status
unaffected

*
affected

Timeline

2024-06-05:Disclosed

Credits

wesley finder

References

https://www.wordfence.com/threat-intel/vulnerabilities/id/061ada09-932f-4d2c-aa9e-c53f1d711c85?source=cve

https://plugins.trac.wordpress.org/browser/qi-addons-for-elementor/tags/1.7.0/inc/shortcodes/info-button/class-qiaddonsforelementor-info-button-shortcode.php#L696

https://plugins.trac.wordpress.org/browser/qi-addons-for-elementor/tags/1.7.0/inc/shortcodes/button/class-qiaddonsforelementor-button-shortcode.php#L1253

https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3096634%40qi-addons-for-elementor%2Ftrunk&old=3092106%40qi-addons-for-elementor%2Ftrunk&sfp_email=&sfph_mail=#file21

cve.org CVE-2024-4364

nvd.nist.gov CVE-2024-4364

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-4364