We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)
Ok

THREATINT
PUBLISHED

CVE-2024-4351

Tutor LMS Pro <= 2.7.0 - Missing Authorization to Privilege Escalation

Reserved:2024-04-30
Published:2024-05-16
Updated:2024-05-16

Description

The Tutor LMS Pro plugin for WordPress is vulnerable to unauthorized access of data, modification of data, loss of data due to a missing capability check on the 'authenticate' function in all versions up to, and including, 2.7.0. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to gain control of an existing administrator account.



HIGH: 8.8CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Problem types

CWE-89 Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')

Product status

Default status
unaffected

*
affected

Timeline

2024-05-15:Disclosed

Credits

Villu Orav finder

References

https://www.wordfence.com/threat-intel/vulnerabilities/id/59859583-49e5-4a80-8659-b9ca7ddc089d?source=cve

https://www.themeum.com/product/tutor-lms/

cve.org CVE-2024-4351

nvd.nist.gov CVE-2024-4351

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-4351