THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-4216

XSS vulnerability in /settings/store API response json payload in pgAdmin 4

Assigner:PostgreSQL (f86ef6dc-4d3a-42ad-8f28-e6d5547a5007)
Reserved:2024-04-25
Published:2024-05-02
Updated:2024-06-06

Description

pgAdmin <= 8.5 is affected by XSS vulnerability in /settings/store API response json payload. This vulnerability allows attackers to execute malicious script at the client end.



HIGH: 7.4CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L

Product status

Default status
affected

Any version before 8.6
affected

References

https://github.com/pgadmin-org/pgadmin4/issues/7282 issue-tracking

cve.org CVE-2024-4216

nvd.nist.gov CVE-2024-4216

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-4216