THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-4146

Improper Authorization in lunary-ai/lunary

Reserved:2024-04-24
Published:2024-06-08
Updated:2024-06-08

Description

In lunary-ai/lunary version v1.2.13, an improper authorization vulnerability exists that allows unauthorized users to access and manipulate projects within an organization they should not have access to. Specifically, the vulnerability is located in the `checkProjectAccess` method within the authorization middleware, which fails to adequately verify if a user has the correct permissions to access a specific project. Instead, it only checks if the user is part of the organization owning the project, overlooking the necessary check against the `account_project` table for explicit project access rights. This flaw enables attackers to gain complete control over all resources within a project, including the ability to create, update, read, and delete any resource, compromising the privacy and security of sensitive information.



CRITICAL: 9.8CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Problem types

CWE-285 Improper Authorization

Product status

Any version before 1.2.26
affected

References

https://huntr.com/bounties/a749e696-b398-4260-b2d0-b0054b9fffa7

https://github.com/lunary-ai/lunary/commit/c43b6c62035f32ca455f66d5fd22ba661648cde7

cve.org CVE-2024-4146

nvd.nist.gov CVE-2024-4146

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-4146