THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Fathom (Privacy friendly web analytics)
Zendesk (Helpdesk and Chat)

Ok

Home | EN
Support
CVE
PUBLISHED

CVE-2024-39742

IBM MQ Container authentication bypass

Assigneribm
Reserved2024-06-28
Published2024-07-08
Updated2024-07-09

Description

IBM MQ Operator 3.2.2 and IBM MQ Operator 2.0.24 could allow a user to bypass authentication under certain configurations due to a partial string comparison vulnerability. IBM X-Force ID: 297169.



HIGH: 8.1CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Problem types

CWE-187 Partial Comparison

Product status

Default status
unaffected

2.0.24, 3.2.2
affected

References

https://www.ibm.com/support/pages/node/7159714 vendor-advisory

https://exchange.xforce.ibmcloud.com/vulnerabilities/297169 vdb-entry

cve.org CVE-2024-39742

nvd.nist.gov CVE-2024-39742

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-39742
© Copyright 2024 THREATINT. Made in Cyprus with +