THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Fathom (Privacy friendly web analytics)
Zendesk (Helpdesk and Chat)

Ok

Home | EN
Support
CVE
PUBLISHED

CVE-2024-3947

WP To Do <= 1.3.0 - Cross-Site Request Forgery via wptodo_settings

AssignerWordfence
Reserved2024-04-18
Published2024-05-30
Updated2024-07-05

Description

The WP To Do plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.3.0. This is due to missing or incorrect nonce validation on the wptodo_settings() function. This makes it possible for unauthenticated attackers to modify the plugin's settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



MEDIUM: 4.3CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Problem types

CWE-352 Cross-Site Request Forgery (CSRF)

Product status

Default status
unaffected

*
affected

Timeline

2024-05-29:Disclosed

Credits

Benedictus Jovan finder

References

https://www.wordfence.com/threat-intel/vulnerabilities/id/c132cfc1-03b3-4616-9a66-871e88c857cb?source=cve

https://plugins.trac.wordpress.org/browser/wp-todo/trunk/inc/Base/Model.php#L304

cve.org CVE-2024-3947

nvd.nist.gov CVE-2024-3947

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-3947
© Copyright 2024 THREATINT. Made in Cyprus with +