THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Fathom (Privacy friendly web analytics)
Zendesk (Helpdesk and Chat)

Ok

Home | EN
Support
CVE
PUBLISHED

CVE-2024-3882

Tenda W30E fromRouteStatic stack-based overflow

AssignerVulDB
Reserved2024-04-16
Published2024-04-16
Updated2024-07-10

Description

EN DE

A vulnerability was found in Tenda W30E 1.0.1.25(633). It has been classified as critical. Affected is the function fromRouteStatic of the file /goform/fromRouteStatic. The manipulation of the argument page leads to stack-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. The identifier of this vulnerability is VDB-260916. NOTE: The vendor was contacted early about this disclosure but did not respond in any way.

Es wurde eine kritische Schwachstelle in Tenda W30E 1.0.1.25(633) ausgemacht. Hiervon betroffen ist die Funktion fromRouteStatic der Datei /goform/fromRouteStatic. Durch das Manipulieren des Arguments page mit unbekannten Daten kann eine stack-based buffer overflow-Schwachstelle ausgenutzt werden. Der Angriff kann über das Netzwerk angegangen werden. Der Exploit steht zur öffentlichen Verfügung.



HIGH: 8.8CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
HIGH: 8.8CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
9.0CVSS:2.0/AV:N/AC:L/Au:S/C:C/I:C/A:C

Problem types

CWE-121 Stack-based Buffer Overflow

Product status

1.0.1.25(633)
affected

Timeline

2024-04-16:Advisory disclosed
2024-04-16:VulDB entry created
2024-04-16:VulDB entry last update

Credits

wxhwxhwxh_mie (VulDB User) reporter

References

https://vuldb.com/?id.260916 (VDB-260916 | Tenda W30E fromRouteStatic stack-based overflow) vdb-entry technical-description

https://vuldb.com/?ctiid.260916 (VDB-260916 | CTI Indicators (IOB, IOC, IOA)) signature permissions-required

https://vuldb.com/?submit.312825 (Submit #312825 | Tenda W30Ev1.0 V1.0.1.25(633) buffer overflow) third-party-advisory

https://github.com/abcdefg-png/IoT-vulnerable/blob/main/Tenda/W30E/fromRouteStatic.md exploit

cve.org CVE-2024-3882

nvd.nist.gov CVE-2024-3882

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-3882
© Copyright 2024 THREATINT. Made in Cyprus with +