THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Fathom (Privacy friendly web analytics)
Zendesk (Helpdesk and Chat)

Ok

Home | EN
Support
CVE
PUBLISHED

CVE-2024-37389

Apache NiFi: Improper Neutralization of Input in Parameter Context Description

Assignerapache
Reserved2024-06-07
Published2024-07-08
Updated2024-07-08

Description

Apache NiFi 1.10.0 through 1.26.0 and 2.0.0-M1 through 2.0.0-M3 support a description field in the Parameter Context configuration that is vulnerable to cross-site scripting. An authenticated user, authorized to configure a Parameter Context, can enter arbitrary JavaScript code, which the client browser will execute within the session context of the authenticated user. Upgrading to Apache NiFi 1.27.0 or 2.0.0-M4 is the recommended mitigation.



MEDIUM: 4.6CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N

Problem types

CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Product status

Default status
unaffected

1.10.0
affected

2.0.0-M1
affected

Timeline

2024-06-07:reported
2024-06-07:confirmed
2024-06-07:resolved

Credits

Akbar Kustirama finder

References

https://lists.apache.org/thread/yso9fr0wtff53nk046h1o83hdyb1lrxh vendor-advisory

cve.org CVE-2024-37389

nvd.nist.gov CVE-2024-37389

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-37389