THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-35242

Composer vulnerable to command injection via malicious git/hg branch names

Reserved:2024-05-14
Published:2024-06-10
Updated:2024-06-10

Description

Composer is a dependency manager for PHP. On the 2.x branch prior to versions 2.2.24 and 2.7.7, the `composer install` command running inside a git/hg repository which has specially crafted branch names can lead to command injection. This requires cloning untrusted repositories. Patches are available in version 2.2.24 for 2.2 LTS or 2.7.7 for mainline. As a workaround, avoid cloning potentially compromised repositories.



HIGH: 8.8CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Problem types

CWE-77: Improper Neutralization of Special Elements used in a Command ('Command Injection')

Product status

>= 2.0, < 2.2.24
affected

>= 2.3, < 2.7.7
affected

References

https://github.com/composer/composer/security/advisories/GHSA-v9qv-c7wm-wgmf

https://github.com/composer/composer/commit/6bd43dff859c597c09bd03a7e7d6443822d0a396

https://github.com/composer/composer/commit/fc57b93603d7d90b71ca8ec77b1c8a9171fdb467

cve.org CVE-2024-35242

nvd.nist.gov CVE-2024-35242

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-35242