THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-35241

Composer vulnerable to command injection via malicious git branch name

Reserved:2024-05-14
Published:2024-06-10
Updated:2024-06-10

Description

Composer is a dependency manager for PHP. On the 2.x branch prior to versions 2.2.24 and 2.7.7, the `status`, `reinstall` and `remove` commands with packages installed from source via git containing specially crafted branch names in the repository can be used to execute code. Patches for this issue are available in version 2.2.24 for 2.2 LTS or 2.7.7 for mainline. As a workaround, avoid installing dependencies via git by using `--prefer-dist` or the `preferred-install: dist` config setting.



HIGH: 8.8CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Problem types

CWE-77: Improper Neutralization of Special Elements used in a Command ('Command Injection')

Product status

>= 2.0, < 2.2.24
affected

>= 2.3, < 2.7.7
affected

References

https://github.com/composer/composer/security/advisories/GHSA-47f6-5gq3-vx9c

https://github.com/composer/composer/commit/b93fc6ca437da35ae73d667d0618749c763b67d4

https://github.com/composer/composer/commit/ee28354ca8d33c15949ad7de2ce6656ba3f68704

cve.org CVE-2024-35241

nvd.nist.gov CVE-2024-35241

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-35241