THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-34716

PrestaShop vulnerable to XSS via customer contact form in FO, through file upload

Reserved:2024-05-07
Published:2024-05-14
Updated:2024-05-14

Description

PrestaShop is an open source e-commerce web application. A cross-site scripting (XSS) vulnerability that only affects PrestaShops with customer-thread feature flag enabled is present starting from PrestaShop 8.1.0 and prior to PrestaShop 8.1.6. When the customer thread feature flag is enabled through the front-office contact form, a hacker can upload a malicious file containing an XSS that will be executed when an admin opens the attached file in back office. The script injected can access the session and the security token, which allows it to perform any authenticated action in the scope of the administrator's right. This vulnerability is patched in 8.1.6. A workaround is to disable the customer-thread feature-flag.



CRITICAL: 9.7CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Problem types

CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Product status

>= 8.1.0, < 8.1.6
affected

References

https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-45vm-3j38-7p78

https://github.com/PrestaShop/PrestaShop/releases/tag/8.1.6

cve.org CVE-2024-34716

nvd.nist.gov CVE-2024-34716

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-34716