THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-34507

Reserved:2024-05-05
Published:2024-05-05
Updated:2024-06-10

Description

An issue was discovered in includes/CommentFormatter/CommentParser.php in MediaWiki before 1.39.7, 1.40.x before 1.40.3, and 1.41.x before 1.41.1. XSS can occur because of mishandling of the 0x1b character, as demonstrated by Special:RecentChanges#%1b0000000.

References

https://phabricator.wikimedia.org/T355538

https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FU2FGUXXK6TMV6R52VRECLC6XCSQQISY/ (FEDORA-2024-2c564b942d) vendor-advisory

cve.org CVE-2024-34507

nvd.nist.gov CVE-2024-34507

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-34507