THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-34145

Reserved:2024-04-30
Published:2024-05-02
Updated:2024-06-06

Description

A sandbox bypass vulnerability involving sandbox-defined classes that shadow specific non-sandbox-defined classes in Jenkins Script Security Plugin 1335.vf07d9ce377a_e and earlier allows attackers with permission to define and run sandboxed scripts, including Pipelines, to bypass the sandbox protection and execute arbitrary code in the context of the Jenkins controller JVM.

Product status

Default status
unaffected

Any version
affected

References

https://www.jenkins.io/security/advisory/2024-05-02/#SECURITY-3341 (Jenkins Security Advisory 2024-05-02) vendor-advisory

http://www.openwall.com/lists/oss-security/2024/05/02/3

cve.org CVE-2024-34145

nvd.nist.gov CVE-2024-34145

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-34145