THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-3150

Privilege Escalation in mintplex-labs/anything-llm

Reserved:2024-04-01
Published:2024-06-06
Updated:2024-06-07

Description

In mintplex-labs/anything-llm, a vulnerability exists in the thread update process that allows users with Default or Manager roles to escalate their privileges to Administrator. The issue arises from improper input validation when handling HTTP POST requests to the endpoint `/workspace/:slug/thread/:threadSlug/update`. Specifically, the application fails to validate or check user input before passing it to the `workspace_thread` Prisma model for execution. This oversight allows attackers to craft a Prisma relation query operation that manipulates the `users` model to change a user's role to admin. Successful exploitation grants attackers the highest level of user privileges, enabling them to see and perform all actions within the system.



HIGH: 8.1CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Problem types

CWE-20 Improper Input Validation

Product status

Any version before 1.0.0
affected

References

https://huntr.com/bounties/745f5c80-14ea-4055-9f15-a066ae93e5a3

https://github.com/mintplex-labs/anything-llm/commit/200bd7f0615347ed2efc07903d510e5a208b0afc

cve.org CVE-2024-3150

nvd.nist.gov CVE-2024-3150

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-3150