THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Fathom (Privacy friendly web analytics)
Zendesk (Helpdesk and Chat)

Ok

Home | EN
Support
CVE
PUBLISHED

CVE-2024-31319

Assignergoogle_android
Reserved2024-03-29
Published2024-07-09
Updated2024-07-11

Description

In updateNotificationChannelFromPrivilegedListener of NotificationManagerService.java, there is a possible cross-user data leak due to a confused deputy. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.

Problem types

Elevation of privilege

Product status

Default status
unaffected

14
affected

13
affected

12L
affected

12
affected

References

https://android.googlesource.com/platform/frameworks/base/+/3cc021bf608fa813a9a40932028fdde2b12a2d5e

https://source.android.com/security/bulletin/2024-06-01

cve.org CVE-2024-31319

nvd.nist.gov CVE-2024-31319

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-31319
© Copyright 2024 THREATINT. Made in Cyprus with +