THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-30395

Junos OS and Junos OS Evolved: A malformed BGP tunnel encapsulation attribute will lead to an rpd crash

Reserved:2024-03-26
Published:2024-04-12
Updated:2024-05-16

Description

An Improper Validation of Specified Type of Input vulnerability in Routing Protocol Daemon (RPD) of Junos OS and Junos OS Evolved allows an unauthenticated, network-based attacker to cause Denial of Service (DoS). If a BGP update is received over an established BGP session which contains a tunnel encapsulation attribute with a specifically malformed TLV, rpd will crash and restart. This issue affects: Junos OS: * all versions before 21.2R3-S7,  * from 21.3 before 21.3R3-S5,  * from 21.4 before 21.4R3-S5,  * from 22.1 before 22.1R3-S5,  * from 22.2 before 22.2R3-S3,  * from 22.3 before 22.3R3-S2,  * from 22.4 before 22.4R3,  * from 23.2 before 23.2R1-S2, 23.2R2. Junos OS Evolved: * all versions before 21.2R3-S7-EVO,  * from 21.3-EVO before 21.3R3-S5-EVO,  * from 21.4-EVO before 21.4R3-S5-EVO,  * from 22.2-EVO before 22.2R3-S3-EVO,  * from 22.3-EVO before 22.3R3-S2-EVO,  * from 22.4-EVO before 22.4R3-EVO,  * from 23.2-EVO before 23.2R1-S2-EVO, 23.2R2-EVO. This is a related but separate issue than the one described in JSA75739



HIGH: 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
HIGH: 8.7CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:L

Problem types

CWE-1287 Improper Validation of Specified Type of Input

Denial of Service (DoS)

Product status

Default status
unaffected

Any version before 21.2R3-S7
affected

21.3 before 21.3R3-S5
affected

21.4 before 21.4R3-S5
affected

22.1 before 22.1R3-S5
affected

22.2 before 22.2R3-S3
affected

22.3 before 22.3R3-S2
affected

22.4 before 22.4R3
affected

23.2 before 23.2R1-S2, 23.2R2
affected

Default status
unaffected

Any version before 21.2R3-S7-EVO
affected

21.3-EVO before 21.3R3-S5-EVO
affected

21.4-EVO before 21.4R3-S5-EVO
affected

22.2-EVO before 22.2R3-S3-EVO
affected

22.3-EVO before 22.3R3-S2-EVO
affected

22.4-EVO before 22.4R3-EVO
affected

23.2-EVO before 23.2R1-S2-EVO, 23.2R2-EVO
affected

Timeline

2024-04-10:Initial Publication

Credits

Juniper SIRT would like to acknowledge and thank Matteo Memelli from Amazon for responsibly reporting this vulnerability. finder

References

https://supportportal.juniper.net/JSA79095 vendor-advisory

https://www.first.org/cvss/calculator/4.0#CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:L technical-description

cve.org CVE-2024-30395

nvd.nist.gov CVE-2024-30395

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-30395