THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-30394

Junos OS and Junos OS Evolved: A specific EVPN type-5 route causes rpd crash

Reserved:2024-03-26
Published:2024-04-12
Updated:2024-05-16

Description

A Stack-based Buffer Overflow vulnerability in the Routing Protocol Daemon (RPD) component of Junos OS and Junos OS Evolved allows an unauthenticated, network-based attacker to cause an rpd crash, leading to Denial of Service (DoS). On all Junos OS and Junos OS Evolved platforms, when EVPN is configured, and a specific EVPN type-5 route is received via BGP, rpd crashes and restarts. Continuous receipt of this specific route will lead to a sustained Denial of Service (DoS) condition. This issue affects: Junos OS: * all versions before 21.2R3-S7, * from 21.4 before 21.4R3-S5, * from 22.1 before 22.1R3-S4, * from 22.2 before 22.2R3-S2, * from 22.3 before 22.3R3-S1, * from 22.4 before 22.4R3, * from 23.2 before 23.2R2. Junos OS Evolved: * all versions before 21.4R3-S5-EVO, * from 22.1-EVO before 22.1R3-S4-EVO, * from 22.2-EVO before 22.2R3-S2-EVO, * from 22.3-EVO before 22.3R3-S1-EVO, * from 22.4-EVO before 22.4R3-EVO, * from 23.2-EVO before 23.2R2-EVO.



HIGH: 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
HIGH: 8.7CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:L

Problem types

CWE-121: Stack-based Buffer Overflow

Denial of Service (DoS)

Product status

Default status
unaffected

Any version before 21.2R3-S7
affected

21.4 before 21.4R3-S5
affected

22.1 before 22.1R3-S4
affected

22.2 before 22.2R3-S2
affected

22.3 before 22.3R3-S1
affected

22.4 before 22.4R3
affected

23.2 before 23.2R2
affected

Default status
unaffected

Any version before 21.4R3-S5-EVO
affected

22.1-EVO before 22.1R3-S4-EVO
affected

22.2-EVO before 22.2R3-S2-EVO
affected

22.3-EVO before 22.3R3-S1-EVO
affected

22.4-EVO before 22.4R3-EVO
affected

23.2-EVO before 23.2R2-EVO
affected

Timeline

2024-04-10:Initial Publication

References

https://supportportal.juniper.net/JSA79094 vendor-advisory

https://www.first.org/cvss/calculator/4.0#CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:L technical-description

cve.org CVE-2024-30394

nvd.nist.gov CVE-2024-30394

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-30394