THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-29894

Cacti Cross-site Scripting vulnerability when using JavaScript based messaging API

Reserved:2024-03-21
Published:2024-05-13
Updated:2024-05-13

Description

Cacti provides an operational monitoring and fault management framework. Versions of Cacti prior to 1.2.27 contain a residual cross-site scripting vulnerability caused by an incomplete fix for CVE-2023-50250. `raise_message_javascript` from `lib/functions.php` now uses purify.js to fix CVE-2023-50250 (among others). However, it still generates the code out of unescaped PHP variables `$title` and `$header`. If those variables contain single quotes, they can be used to inject JavaScript code. An attacker exploiting this vulnerability could execute actions on behalf of other users. This ability to impersonate users could lead to unauthorized changes to settings. Version 1.2.27 fixes this issue.



MEDIUM: 5.4CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L

Problem types

CWE-116: Improper Encoding or Escaping of Output

CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Product status

< 1.2.27
affected

References

https://github.com/Cacti/cacti/security/advisories/GHSA-grj5-8fcj-34gh

https://github.com/Cacti/cacti/security/advisories/GHSA-xwqc-7jc4-xm73

cve.org CVE-2024-29894

nvd.nist.gov CVE-2024-29894

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-29894