THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-29893

Uncontrolled Resource Consumption vulnerability in ArgoCD's repo server

Assigner:GitHub_M (a0819718-46f1-4df5-94e2-005712e83aaa)
Reserved:2024-03-21
Published:2024-03-29
Updated:2024-06-06

Description

Argo CD is a declarative, GitOps continuous delivery tool for Kubernetes. All versions of ArgoCD starting from v2.4 have a bug where the ArgoCD repo-server component is vulnerable to a Denial-of-Service attack vector. Specifically, it's possible to crash the repo server component through an out of memory error by pointing it to a malicious Helm registry. The loadRepoIndex() function in the ArgoCD's helm package, does not limit the size nor time while fetching the data. It fetches it and creates a byte slice from the retrieved data in one go. If the registry is implemented to push data continuously, the repo server will keep allocating memory until it runs out of it. A patch for this vulnerability has been released in v2.10.3, v2.9.8, and v2.8.12.



MEDIUM: 6.5CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Problem types

CWE-400: Uncontrolled Resource Consumption

Product status

>= 2.4.0, < 2.8.14
affected

>= 2.9.0, < 2.9.10
affected

>= 2.10.0, < 2.10.5
affected

References

https://github.com/argoproj/argo-cd/security/advisories/GHSA-jhwx-mhww-rgc3

https://github.com/argoproj/argo-cd/commit/14f681e3ee7c38731943b98f92277e88a3db109d

https://github.com/argoproj/argo-cd/commit/36b8a12a38f8d92d55bffc81deed44389bf6eb59

https://github.com/argoproj/argo-cd/commit/3e5a878f6e30d935fa149723ea2a2e93748fcddd

cve.org CVE-2024-29893

nvd.nist.gov CVE-2024-29893

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-29893