THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Fathom (Privacy friendly web analytics)
Zendesk (Helpdesk and Chat)

Ok

Home | EN
Support
CVE
PUBLISHED

CVE-2024-2840

AssignerWordfence
Reserved2024-03-22
Published2024-05-02
Updated2024-07-05

Description

The Enhanced Media Library plugin for WordPress is vulnerable to Stored Cross-Site Scripting via media upload functionality in all versions up to, and including, 2.8.9 due to the plugin allowing 'dfxp' files to be uploaded. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



MEDIUM: 5.4CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Problem types

CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Product status

Default status
unaffected

*
affected

Timeline

2024-04-15:Disclosed

Credits

Tim Coen finder

References

https://www.wordfence.com/threat-intel/vulnerabilities/id/15b30ecb-e3ce-4092-841b-3a1b2553596a?source=cve

https://plugins.trac.wordpress.org/changeset?old_path=/enhanced-media-library/tags/2.8.9&new_path=/enhanced-media-library/tags/2.8.10&sfp_email=&sfph_mail=

cve.org CVE-2024-2840

nvd.nist.gov CVE-2024-2840

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-2840
© Copyright 2024 THREATINT. Made in Cyprus with +