THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-27815

Reserved:2024-02-26
Published:2024-06-10
Updated:2024-06-12

Description

An out-of-bounds write issue was addressed with improved input validation. This issue is fixed in tvOS 17.5, visionOS 1.2, iOS 17.5 and iPadOS 17.5, watchOS 10.5, macOS Sonoma 14.5. An app may be able to execute arbitrary code with kernel privileges.

Problem types

An app may be able to execute arbitrary code with kernel privileges

Product status

Any version before 17.5
affected

Any version before 14.5
affected

Any version before 1.2
affected

Any version before 10.5
affected

Any version before 17.5
affected

References

https://support.apple.com/en-us/HT214101

https://support.apple.com/en-us/HT214106

https://support.apple.com/en-us/HT214108

https://support.apple.com/en-us/HT214104

https://support.apple.com/en-us/HT214102

https://support.apple.com/kb/HT214102

https://support.apple.com/kb/HT214104

https://support.apple.com/kb/HT214106

https://support.apple.com/kb/HT214101

https://support.apple.com/kb/HT214108

http://seclists.org/fulldisclosure/2024/Jun/5

cve.org CVE-2024-27815

nvd.nist.gov CVE-2024-27815

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-27815