THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Fathom (Privacy friendly web analytics)
Zendesk (Helpdesk and Chat)

Ok

Home | EN
Support
CVE
PUBLISHED

CVE-2024-27309

Apache Kafka: Potential incorrect access control during migration from ZK mode to KRaft mode

Assignerapache
Reserved2024-02-22
Published2024-04-12
Updated2024-07-08

Description

While an Apache Kafka cluster is being migrated from ZooKeeper mode to KRaft mode, in some cases ACLs will not be correctly enforced. Two preconditions are needed to trigger the bug: 1. The administrator decides to remove an ACL 2. The resource associated with the removed ACL continues to have two or more other ACLs associated with it after the removal. When those two preconditions are met, Kafka will treat the resource as if it had only one ACL associated with it after the removal, rather than the two or more that would be correct. The incorrect condition is cleared by removing all brokers in ZK mode, or by adding a new ACL to the affected resource. Once the migration is completed, there is no metadata loss (the ACLs all remain). The full impact depends on the ACLs in use. If only ALLOW ACLs were configured during the migration, the impact would be limited to availability impact. if DENY ACLs were configured, the impact could include confidentiality and integrity impact depending on the ACLs configured, as the DENY ACLs might be ignored due to this vulnerability during the migration period.

Problem types

CWE-863 Incorrect Authorization

Product status

Default status
unaffected

3.5.0
affected

3.6.0
affected

References

https://lists.apache.org/thread/6536rmzyg076lzzdw2xdktvnz163mjpy vendor-advisory

http://www.openwall.com/lists/oss-security/2024/04/12/3

https://security.netapp.com/advisory/ntap-20240705-0002/

cve.org CVE-2024-27309

nvd.nist.gov CVE-2024-27309

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-27309
© Copyright 2024 THREATINT. Made in Cyprus with +