We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)
Ok

THREATINT
PUBLISHED

CVE-2024-27073

media: ttpci: fix two memleaks in budget_av_attach

Reserved:2024-02-19
Published:2024-05-01
Updated:2024-05-13

Description

In the Linux kernel, the following vulnerability has been resolved: media: ttpci: fix two memleaks in budget_av_attach When saa7146_register_device and saa7146_vv_init fails, budget_av_attach should free the resources it allocates, like the error-handling of ttpci_budget_init does. Besides, there are two fixme comment refers to such deallocations.

Product status

Default status
unaffected

1da177e4c3f4 before af37aed04997
affected

1da177e4c3f4 before 910363473e4b
affected

1da177e4c3f4 before 24e51d6eb578
affected

1da177e4c3f4 before 55ca0c7eae84
affected

1da177e4c3f4 before 7393c681f9aa
affected

1da177e4c3f4 before 1597cd1a88cf
affected

1da177e4c3f4 before 656b8cc123d7
affected

1da177e4c3f4 before d0b07f712bf6
affected

Default status
affected

2.6.12
affected

Any version before 2.6.12
unaffected

5.4.273
unaffected

5.10.214
unaffected

5.15.153
unaffected

6.1.83
unaffected

6.6.23
unaffected

6.7.11
unaffected

6.8.2
unaffected

6.9
unaffected

References

https://git.kernel.org/stable/c/af37aed04997e644f7e1b52b696b62dcae3cc016

https://git.kernel.org/stable/c/910363473e4bf97da3c350e08d915546dd6cc30b

https://git.kernel.org/stable/c/24e51d6eb578b82ff292927f14b9f5ec05a46beb

https://git.kernel.org/stable/c/55ca0c7eae8499bb96f4e5d9b26af95e89c4e6a0

https://git.kernel.org/stable/c/7393c681f9aa05ffe2385e8716989565eed2fe06

https://git.kernel.org/stable/c/1597cd1a88cfcdc4bf8b1b44cd458fed9a5a5d63

https://git.kernel.org/stable/c/656b8cc123d7635dd399d9f02594f27aa797ac3c

https://git.kernel.org/stable/c/d0b07f712bf61e1a3cf23c87c663791c42e50837

cve.org CVE-2024-27073

nvd.nist.gov CVE-2024-27073

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-27073