THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-27035

f2fs: compress: fix to guarantee persisting compressed blocks by CP

Reserved:2024-02-19
Published:2024-05-01
Updated:2024-05-13

Description

In the Linux kernel, the following vulnerability has been resolved: f2fs: compress: fix to guarantee persisting compressed blocks by CP If data block in compressed cluster is not persisted with metadata during checkpoint, after SPOR, the data may be corrupted, let's guarantee to write compressed page by checkpoint.

Product status

Default status
unaffected

4c8ff7095bef before e54cce813725
affected

4c8ff7095bef before 82704e598d7b
affected

4c8ff7095bef before c3311694b9bc
affected

4c8ff7095bef before 57e8b17d0522
affected

4c8ff7095bef before 8a430dd49e9c
affected

Default status
affected

5.6
affected

Any version before 5.6
unaffected

6.1.83
unaffected

6.6.23
unaffected

6.7.11
unaffected

6.8.2
unaffected

6.9
unaffected

References

https://git.kernel.org/stable/c/e54cce8137258a550b49cae45d09e024821fb28d

https://git.kernel.org/stable/c/82704e598d7b33c7e45526e34d3c585426319bed

https://git.kernel.org/stable/c/c3311694b9bcced233548574d414c91d39214684

https://git.kernel.org/stable/c/57e8b17d0522c8f4daf0c4d9969b4d7358033532

https://git.kernel.org/stable/c/8a430dd49e9cb021372b0ad91e60aeef9c6ced00

cve.org CVE-2024-27035

nvd.nist.gov CVE-2024-27035

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-27035