THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-2548

Path Traversal in parisneo/lollms-webui

Reserved:2024-03-15
Published:2024-06-06
Updated:2024-06-07

Description

A path traversal vulnerability exists in the parisneo/lollms-webui application, specifically within the `lollms_core/lollms/server/endpoints/lollms_binding_files_server.py` and `lollms_core/lollms/security.py` files. Due to inadequate validation of file paths between Windows and Linux environments using `Path(path).is_absolute()`, attackers can exploit this flaw to read any file on the system. This issue affects the latest version of LoLLMs running on the Windows platform. The vulnerability is triggered when an attacker sends a specially crafted request to the `/user_infos/{path:path}` endpoint, allowing the reading of arbitrary files, as demonstrated with the `win.ini` file. The issue has been addressed in version 9.5 of the software.



HIGH: 7.5CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Problem types

CWE-36 Absolute Path Traversal

Product status

Any version before 9.5
affected

References

https://huntr.com/bounties/65979513-db0d-46fd-9977-fcd73bcd8a41

https://github.com/parisneo/lollms-webui/commit/49b0332e98d42dd5204dda53dee410b160106265

cve.org CVE-2024-2548

nvd.nist.gov CVE-2024-2548

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-2548