THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-2509

Gutenberg Blocks by Kadence Blocks < 3.2.26 - Contributor+ Stored XSS

Assigner:WPScan (1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81)
Reserved:2024-03-15
Published:2024-04-05
Updated:2024-06-10

Description

The Gutenberg Blocks by Kadence Blocks WordPress plugin before 3.2.26 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks

Problem types

CWE-79 Cross-Site Scripting (XSS)

Product status

Default status
unaffected

Any version before 3.2.26
affected

Credits

Dmitrii Ignatyev finder

WPScan coordinator

References

https://wpscan.com/vulnerability/dec4a632-e04b-4fdd-86e4-48304b892a4f/ exploit vdb-entry technical-description

https://research.cleantalk.org/cve-2024-2509/

cve.org CVE-2024-2509

nvd.nist.gov CVE-2024-2509

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-2509