THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-2408

PHP is vulnerable to the Marvin Attack

Reserved:2024-03-12
Published:2024-06-09
Updated:2024-06-09

Description

The openssl_private_decrypt function in PHP, when using PKCS1 padding (OPENSSL_PKCS1_PADDING, which is the default), is vulnerable to the Marvin Attack unless it is used with an OpenSSL version that includes the changes from this pull request: https://github.com/openssl/openssl/pull/13817 (rsa_pkcs1_implicit_rejection). These changes are part of OpenSSL 3.2 and have also been backported to stable versions of various Linux distributions, as well as to the PHP builds provided for Windows since the previous release. All distributors and builders should ensure that this version is used to prevent PHP from being vulnerable. PHP Windows builds for the versions 8.1.29, 8.2.20 and 8.3.8 and above include OpenSSL patches that fix the vulnerability.

Product status

Default status
affected

8.1.* before 8.1.29
affected

8.2.* before 8.2.20
affected

8.3.* before 8.3.8
affected

Credits

Hubert Kario reporter

References

https://github.com/php/php-src/security/advisories/GHSA-hh26-4ppw-5864

https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/PKGTQUOA2NTZ3RXN22CSAUJPIRUYRB4B/

https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/W45DBOH56NQDRTOM2DN2LNA2FZIMC3PK/

cve.org CVE-2024-2408

nvd.nist.gov CVE-2024-2408

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-2408