THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-23643

GeoServer Stored Cross-Site Scripting (XSS) vulnerability in GWC Seed Form

Reserved:2024-01-19
Published:2024-03-20
Updated:2024-06-11

Description

GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 2.23.2 and 2.24.1 that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in the GeoServer catalog that will execute in the context of another administrator’s browser when viewed in the GWC Seed Form. Access to the GWC Seed Form is limited to full administrators by default and granting non-administrators access to this endpoint is not recommended. Versions 2.23.2 and 2.24.1 contain a fix for this issue.



MEDIUM: 4.8CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Problem types

CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Product status

< 2.23.2
affected

= 2.24.0
affected

References

https://github.com/geoserver/geoserver/security/advisories/GHSA-56r3-f536-5gf7

https://github.com/GeoWebCache/geowebcache/issues/1172

https://github.com/GeoWebCache/geowebcache/pull/1174

https://github.com/GeoWebCache/geowebcache/commit/9d010e09c784690ada8af43f594461a2553a62f0

cve.org CVE-2024-23643

nvd.nist.gov CVE-2024-23643

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-23643