THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-2213

Improper Authentication in zenml-io/zenml

Reserved:2024-03-06
Published:2024-06-06
Updated:2024-06-07

Description

An issue was discovered in zenml-io/zenml versions up to and including 0.55.4. Due to improper authentication mechanisms, an attacker with access to an active user session can change the account password without needing to know the current password. This vulnerability allows for unauthorized account takeover by bypassing the standard password change verification process. The issue was fixed in version 0.56.3.



LOW: 3.3CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Problem types

CWE-287 Improper Authentication

Product status

Any version before 0.56.3
affected

References

https://huntr.com/bounties/8f5534ac-fd08-4b8b-8c2e-35949aa36e48

https://github.com/zenml-io/zenml/commit/58cb3d987372c91eb605853c35325701733337c2

cve.org CVE-2024-2213

nvd.nist.gov CVE-2024-2213

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-2213