THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-21610

Junos OS: MX Series: In a scaled subscriber scenario if CoS information is gathered mgd processes gets stuck

Reserved:2023-12-27
Published:2024-04-12
Updated:2024-05-16

Description

An Improper Handling of Exceptional Conditions vulnerability in the Class of Service daemon (cosd) of Juniper Networks Junos OS on MX Series allows an authenticated, network-based attacker with low privileges to cause a limited Denial of Service (DoS). In a scaled subscriber scenario when specific low privileged commands, received over NETCONF, SSH or telnet, are handled by cosd on behalf of mgd, the respective child management daemon (mgd) processes will get stuck. In case of (Netconf over) SSH this leads to stuck SSH sessions, so that when the connection-limit for SSH is reached new sessions can't be established anymore. A similar behavior will be seen for telnet etc. Stuck mgd processes can be monitored by executing the following command:   user@host> show system processes extensive | match mgd | match sbwait This issue affects Juniper Networks Junos OS on MX Series: All versions earlier than 20.4R3-S9; 21.2 versions earlier than 21.2R3-S7; 21.3 versions earlier than 21.3R3-S5; 21.4 versions earlier than 21.4R3-S5; 22.1 versions earlier than 22.1R3-S4; 22.2 versions earlier than 22.2R3-S3; 22.3 versions earlier than 22.3R3-S2; 22.4 versions earlier than 22.4R3; 23.2 versions earlier than 23.2R1-S2, 23.2R2.



MEDIUM: 4.3CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
MEDIUM: 5.3CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Problem types

CWE-755 Improper Handling of Exceptional Conditions

Denial of Service (DoS)

Product status

Default status
unaffected

Any version before 20.4R3-S9
affected

21.2 before 21.2R3-S7
affected

21.3 before 21.3R3-S5
affected

21.4 before 21.4R3-S5
affected

22.1 before 22.1R3-S4
affected

22.2 before 22.2R3-S3
affected

22.3 before 22.3R3-S2
affected

22.4 before 22.4R3
affected

23.2 before 23.2R1-S2, 23.2R2
affected

Timeline

2024-04-10:Initial Publication

References

http://supportportal.juniper.net/JSA75751 vendor-advisory

https://www.first.org/cvss/calculator/4.0#CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N technical-description

cve.org CVE-2024-21610

nvd.nist.gov CVE-2024-21610

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-21610