THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Fathom (Privacy friendly web analytics)
Zendesk (Helpdesk and Chat)

Ok

Home | EN
Support
CVE
PUBLISHED

CVE-2024-21525

Assignersnyk
Reserved2023-12-22
Published2024-07-10
Updated2024-07-10

Description

All versions of the package node-twain are vulnerable to Improper Check or Handling of Exceptional Conditions due to the length of the source data not being checked. Creating a new twain.TwainSDK with a productName or productFamily, manufacturer, version.info property of length >= 34 chars leads to a buffer overflow vulnerability.



HIGH: 8.3CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L/E:P

Problem types

Improper Check or Handling of Exceptional Conditions

Credits

Alessio Della Libera

References

https://security.snyk.io/vuln/SNYK-JS-NODETWAIN-6421153

https://gist.github.com/dellalibera/55b87634a6c360e5be22a715f0566c99

cve.org CVE-2024-21525

nvd.nist.gov CVE-2024-21525

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-21525
© Copyright 2024 THREATINT. Made in Cyprus with +