THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-2032

Race Condition Vulnerability in zenml-io/zenml

Reserved:2024-02-29
Published:2024-06-06
Updated:2024-06-07

Description

A race condition vulnerability exists in zenml-io/zenml versions up to and including 0.55.3, which allows for the creation of multiple users with the same username when requests are sent in parallel. This issue was fixed in version 0.55.5. The vulnerability arises due to insufficient handling of concurrent user creation requests, leading to data inconsistencies and potential authentication problems. Specifically, concurrent processes may overwrite or corrupt user data, complicating user identification and posing security risks. This issue is particularly concerning for APIs that rely on usernames as input parameters, such as PUT /api/v1/users/test_race, where it could lead to further complications.



LOW: 3.1CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:L

Problem types

CWE-366 Race Condition within a Thread

Product status

Any version before 0.55.5
affected

References

https://huntr.com/bounties/6199cd5d-611f-4ea9-96c5-52a952ba5a56

https://github.com/zenml-io/zenml/commit/afcaf741ef9114c9b32f722f101b97de3d8d147b

cve.org CVE-2024-2032

nvd.nist.gov CVE-2024-2032

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-2032