THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-1897

Assigner:Wordfence (b15e7b5b-3da4-40ae-a43c-f7aa60e62599)
Reserved:2024-02-26
Published:2024-05-02
Updated:2024-06-06

Description

The Grid Gallery – Photo Image Grid Gallery plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 1.4.3 via deserialization via shortcode of untrusted input from the awl_gg_settings_ meta value. This makes it possible for authenticated attackers, with contributor access and above, to inject a PHP Object. No POP chain is present in the vulnerable plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.



HIGH: 7.5CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Problem types

CWE-502 Deserialization of Untrusted Data

Product status

Default status
unaffected

*
affected

Timeline

2024-04-29:Disclosed

Credits

Francesco Carlucci finder

References

https://www.wordfence.com/threat-intel/vulnerabilities/id/39f5777b-38b0-4fc6-909d-61eaa1de6173?source=cve

https://plugins.trac.wordpress.org/browser/new-grid-gallery/tags/1.4.0/grid-gallery-shortcode.php

cve.org CVE-2024-1897

nvd.nist.gov CVE-2024-1897

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-1897