THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2024-1738

Incorrect Authorization in lunary-ai/lunary

Reserved:2024-02-22
Published:2024-04-16
Updated:2024-05-15

Description

An incorrect authorization vulnerability exists in the lunary-ai/lunary repository, specifically within the evaluations.get route in the evaluations API endpoint. This vulnerability allows unauthorized users to retrieve the results of any organization's evaluation by simply knowing the evaluation ID, due to the lack of project ID verification in the SQL query. As a result, attackers can gain access to potentially private data contained within the evaluation results.



HIGH: 7.5CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Problem types

CWE-863 Incorrect Authorization

Product status

Any version before 1.2.4
affected

References

https://huntr.com/bounties/f68ef361-7a5d-4272-9c2f-414baf074309

https://github.com/lunary-ai/lunary/commit/a4e61122e61dc31460cfbe54d15fae389cc440ce

cve.org CVE-2024-1738

nvd.nist.gov CVE-2024-1738

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2024-1738