THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2023-6966

The Moneytizer <= 9.5.20 - Missing Authorization via multiple AJAX actions

Reserved:2023-12-19
Published:2024-06-06
Updated:2024-06-07

Description

The The Moneytizer plugin for WordPress is vulnerable to unauthorized access of data, modification of data, and loss of data due to a missing capability check on multiple AJAX functions in the /core/core_ajax.php file in all versions up to, and including, 9.5.20. This makes it possible for authenticated attackers, with subscriber access and above, to update and retrieve billing and bank details, update and reset the plugin's settings, and update languages as well as other lower-severity actions.



HIGH: 8.1CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Problem types

CWE-284 Improper Access Control

Product status

Default status
unaffected

*
affected

Timeline

2024-06-05:Disclosed

Credits

Francesco Carlucci finder

References

https://www.wordfence.com/threat-intel/vulnerabilities/id/71823e36-3899-4253-a1d2-c6f8921d18dc?source=cve

https://plugins.trac.wordpress.org/browser/the-moneytizer/trunk/core/core_ajax.php

cve.org CVE-2023-6966

nvd.nist.gov CVE-2023-6966

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2023-6966