We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)
Ok

THREATINT
PUBLISHED

CVE-2023-6267

Quarkus: json payload getting processed prior to security checks when rest resources are used with annotations.

Reserved:2023-11-23
Published:2024-01-25
Updated:2024-05-13

Description

A flaw was found in the json payload. If annotation based security is used to secure a REST resource, the JSON body that the resource may consume is being processed (deserialized) prior to the security constraints being evaluated and applied. This does not happen with configuration based security.



HIGH: 8.6CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Problem types

Improper Handling of Insufficient Permissions or Privileges

Product status

Default status
affected

2.13.9.Final-redhat-00003 before *
unaffected

Default status
affected

3.2.9.Final-redhat-00003 before *
unaffected

Default status
affected

Default status
affected

Default status
unaffected

Default status
unaffected

Timeline

2023-11-23:Reported to Red Hat.
2024-01-24:Made public.

References

https://access.redhat.com/errata/RHSA-2024:0494 (RHSA-2024:0494) vendor-advisory

https://access.redhat.com/errata/RHSA-2024:0495 (RHSA-2024:0495) vendor-advisory

https://access.redhat.com/security/cve/CVE-2023-6267 vdb-entry

https://bugzilla.redhat.com/show_bug.cgi?id=2251155 (RHBZ#2251155) issue-tracking

cve.org CVE-2023-6267

nvd.nist.gov CVE-2023-6267

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2023-6267