THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Zendesk (Helpdesk and Chat)

Ok

PUBLISHED

CVE-2023-38380

Reserved:2023-07-17
Published:2023-12-12
Updated:2024-06-11

Description

A vulnerability has been identified in SIMATIC CP 1242-7 V2 (incl. SIPLUS variants) (All versions < V3.4.29), SIMATIC CP 1243-1 (incl. SIPLUS variants) (All versions < V3.4.29), SIMATIC CP 1243-1 DNP3 (incl. SIPLUS variants) (All versions), SIMATIC CP 1243-1 IEC (incl. SIPLUS variants) (All versions < V3.4.29), SIMATIC CP 1243-7 LTE (All versions < V3.4.29), SIMATIC CP 1243-8 IRC (6GK7243-8RX30-0XE0) (All versions < V3.4.29), SIMATIC CP 1542SP-1 (6GK7542-6UX00-0XE0) (All versions < V2.3), SIMATIC CP 1542SP-1 IRC (6GK7542-6VX00-0XE0) (All versions < V2.3), SIMATIC CP 1543-1 (6GK7543-1AX00-0XE0) (All versions < V3.0.37), SIMATIC CP 1543SP-1 (6GK7543-6WX00-0XE0) (All versions < V2.3), SINAMICS S210 (6SL5...) (All versions >= V6.1 < V6.1 HF2), SIPLUS ET 200SP CP 1542SP-1 IRC TX RAIL (6AG2542-6VX00-4XE0) (All versions < V2.3), SIPLUS ET 200SP CP 1543SP-1 ISEC (6AG1543-6WX00-7XE0) (All versions < V2.3), SIPLUS ET 200SP CP 1543SP-1 ISEC TX RAIL (6AG2543-6WX00-4XE0) (All versions < V2.3), SIPLUS NET CP 1543-1 (6AG1543-1AX00-2XE0) (All versions < V3.0.37). The webserver implementation of the affected products does not correctly release allocated memory after it has been used. An attacker with network access could use this vulnerability to cause a denial-of-service condition in the webserver of the affected product.



HIGH: 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P/RL:O/RC:C
HIGH: 8.7CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Problem types

CWE-401: Missing Release of Memory after Effective Lifetime

Product status

Default status
unknown

Any version before V3.4.29
affected

Default status
unknown

Any version before V3.4.29
affected

Default status
unknown

Any version before *
affected

Default status
unknown

Any version before V3.4.29
affected

Default status
unknown

Any version before V3.4.29
affected

Default status
unknown

Any version before V3.4.29
affected

Default status
unknown

Any version before V2.3
affected

Default status
unknown

Any version before V2.3
affected

Default status
unknown

Any version before V3.0.37
affected

Default status
unknown

Any version before V2.3
affected

Default status
unknown

V6.1 before V6.1 HF2
affected

Default status
unknown

Any version before V2.3
affected

Default status
unknown

Any version before V2.3
affected

Default status
unknown

Any version before V2.3
affected

Default status
unknown

Any version before V3.0.37
affected

References

https://cert-portal.siemens.com/productcert/pdf/ssa-693975.pdf

https://cert-portal.siemens.com/productcert/html/ssa-693975.html

https://cert-portal.siemens.com/productcert/html/ssa-139628.html

https://cert-portal.siemens.com/productcert/html/ssa-625862.html

cve.org CVE-2023-38380

nvd.nist.gov CVE-2023-38380

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2023-38380