THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Fathom (Privacy friendly web analytics)
Zendesk (Helpdesk and Chat)

Ok

Home | EN
Support
CVE
PUBLISHED

CVE-2023-32174

Unified Automation UaGateway NodeManagerOpcUa Use-After-Free Remote Code Execution Vulnerability

Assignerzdi
Reserved2023-05-03
Published2024-05-03
Updated2024-07-10

Description

Unified Automation UaGateway NodeManagerOpcUa Use-After-Free Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Unified Automation UaGateway. Authentication is required to exploit this vulnerability when the product is in its default configuration. The specific flaw exists within the handling of NodeManagerOpcUa objects. The issue results from the lack of validating the existence of an object prior to performing operations on the object. An attacker can leverage this vulnerability to execute code in the context of SYSTEM. Was ZDI-CAN-20577.



CRITICAL: 9.1CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

Problem types

CWE-416: Use After Free

Product status

Default status
unknown

R.47.0.0 AutoCAD 2021 & R.47.0.0 AutoCAD LT 2021
affected

References

https://www.zerodayinitiative.com/advisories/ZDI-23-780/ (ZDI-23-780)

https://documentation.unified-automation.com/uagateway/1.5.14/CHANGELOG.txt (vendor-provided URL) vendor-advisory

cve.org CVE-2023-32174

nvd.nist.gov CVE-2023-32174

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2023-32174